چهارشنبه ۳۰ خرداد ۱۴۰۳ , 19 Jun 2024
جالب است ۰
آسیب‌پذیری در پروتکل SAML به مهاجم اجازه می‌دهد کد جاوا اسکریپت دلخواه را به صفحه ابرداده SAML تولید شده، تزریق کند که منجر به سرقت احتمالی کوکی‌های کاربر یا توکن‌های احراز هویت می‌شود.
منبع : NIST
آسیب‌پذیری در پروتکل SAML به مهاجم اجازه می‌دهد کد جاوا اسکریپت دلخواه را به صفحه ابرداده SAML تولید شده، تزریق کند که منجر به سرقت احتمالی کوکی‌های کاربر یا توکن‌های احراز هویت می‌شود.
 
به گزارش افتانا، یک آسیب‌پذیری XSS با شناسه CVE-2024-5478 و شدت 7.4 (بالا) در نقطه پایانی SAML metadata  (`/auth/saml/${org?.id}/metadata`) کشف شده است.
 
این آسیب‌پذیری به دلیل عدم موفقیت برنامه در escape یا اعتبارسنجی پارامتر `orgId` ارائه شده توسط کاربر قبل از ترکیب آن در پاسخ تولید شده، ایجاد می‎‌شود. به طور خاص نقطه پایانی، پاسخ‌های XML را برای ابرداده SAML ایجاد می‌کند، جایی که پارامتر `orgId`مستقیما بدون پاکسازی یا اعتبارسنجی مناسب در ساختار XML تعبیه می‌شود. این نقص به مهاجم اجازه می‌دهد تا کد جاوا اسکریپت دلخواه را به صفحه ابرداده SAML تولید شده، تزریق کند که منجر به سرقت احتمالی کوکی‌های کاربر یا توکن‌های احراز هویت می‌شود.
 
بر اساس بردار حمله این آسیب‌پذیری CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N: بهره‌برداری از آن از طریق شبکه خارجی و از راه دور امکان‌پذیر است (AV:N) و به‌راحتی قابل تکرار است و چندان به شرایط خاصی نیاز نیست(AC:L)، برای انجام حمله به هیچ حساب کاربری با سطح دسترسی خاصی نیاز نیست (PR:N) و به تعامل با کاربر نیاز دارد(UI:R)، بهره‌برداری از آسیب‌پذیری مذکور بر سایر منابع امنیتی تأثیر می‌گذارد (S:C) و یک ضلع از سه ضلع امنیت به میزان کمی تحت تأثیر قرار می‌گیرند ( C:H/I:N/A:N).
 
این آسیب‌پذیری نقطه پایانی SAML metadata  (`/auth/saml/${org?.id}/metadata`) از lunary-ai/lunary نسخه 1.2.7 را تحت تاثیر قرار می‌دهد.
 
 
کد مطلب : 22253
https://aftana.ir/vdcdsx0x.yt0xk6a22y.html
ارسال نظر
نام شما
آدرس ايميل شما
کد امنيتی