شنبه ۲۳ تير ۱۴۰۳ , 13 Jul 2024
جالب است ۰
کارشناسان امنیت سایبری یک نوع آسیب‌پذیری خطرناک در پردازنده‌های شرکت AMD کشف کرده‌اند.
کارشناسان امنیت سایبری یک نوع آسیب‌پذیری خطرناک در پردازنده‌های شرکت AMD کشف کرده‌اند.
 
به گزارش افتانا، یک آسیب‌پذیری با شناسه CVE-2023-20592 کشف شده است که مهاجم از طریق آن می‌تواند حمله CacheWarp که مبتنی بر نرم‌افزار و از نوع fault injection می‌باشد را انجام داده و از این طریق ماشین‌های مجازی محافظت شده توسط AMD SEV را با هدف قرار دادن memory write ها جهت ارتقاء سطح دسترسی، مورد هدف قرار داده و از راه دور کد مورد نظرش را اجرا کند.
 
این حمله جدید از نقص‌های موجود در تکنولوژی‌های Secure Encrypted Virtualization-Encrypted State (SEV-ES) و Secure Encrypted Virtualization-Secure Nested Paging (SEV-SNP) بهره‌برداری می‌کند که برای محافظت از hypervisorهای مخرب و کاهش سطح حمله ماشین‌های مجازی طراحی شده‌اند و با رمزنگاری داده ماشین مجازی این کار را انجام می‌دهند.
 
CacheWarp یک حمله جدید مبتنی بر نرم‌افزار بر روی AMD SEV-ES و همچنین SEV-SNP می‌باشد. این حمله از امکان بازگردانی cache lineهای تغییر یافته ماشین مجازی مهمان به حالت قبلی (stale) بهره‌برداری می‌کند. بر اساس مطالعات صورت گرفته، یک حمله بر روی RSA در کتابخانه Intel IPP crypto انجام شده که تمام کلیدهای خصوصی بازیابی شده است. همچنین ورود به سرور OpenSSH بدون احراز هویت و افزایش سطح دسترسی به روت با استفاده از باینری sudo انجام شده است.
 
در حملات موفق، مهاجم می‌تواند به عنوان مثال متغیر استفاده شده برای احراز هویت را به یک نسخه قبلی برگرداند و اطلاعات احراز هویت قبلی را سرقت کند. همچنین بهره‌برداری از CacheWarp به مهاجم اجازه می‌دهد آدرس‌های return را روی stack دستکاری کند.
 
آسیب‌پذیری CacheWarp تنها سیستم‌های AMD با پردازنده‌های زیر را که از SEV پشتیبانی می‌کنند تحت تاثیر خود قرار می‌دهد:
 
•    1st Gen AMD EPYC Processors (SEV and SEV-ES)
•    2nd Gen AMD EPYC Processors (SEV and SEV-ES)
•    3rd Gen AMD EPYC Processors (SEV, SEV-ES, SEV-SNP)
 
طبق اطلاعات منتشر شده توسط AMD این نقص، پردازنده‌های نسل چهارم Genoa EPYC با ریزمعماری Zen 4 را تحت تاثیر قرار نمی‌دهد.
 
به گفته شرکت AMD هیچگونه اقدام کاهشی برای نسل‌های اول یا دوم پردازنده‌های EPYC وجود ندارد زیرا ویژگی‌های SEV و SEV-ES عملکرد محافظت برای حافظه مهمان ماشین مجازی را ندارند در حالیکه ویژگی SEV-SNP نیز در آن‌ها در دسترس نیست. اما این شرکت برای مشتریانی که از پردازنده‌های نسل سوم EPYC شرکت AMD استفاده می‌کنند که ویژگی Encrypted Virtualization-Secure Nested Paging (SEV-SNP)  در آن‌ها فعال است، یک وصله امنیتی برای firmware منتشر کرده است.
کد مطلب : 21654
https://aftana.ir/vdchk-ni.23nzmdftt2.html
ارسال نظر
نام شما
آدرس ايميل شما
کد امنيتی